Portal Login Issues
Incident Report for
RAM Tracking
Resolved
The incident has been resolved and was related to a performance issue with our authentication system.
Posted
Feb
04
,
2026
-
10:24
UTC
Investigating
We are currently investigating reports of users being unable to login.
Posted
Feb
04
,
2026
-
08:43
UTC
This incident affected: RAM Assist (Assist Website), RAM Live (Live Website), and RAM Tracking (Tracking Website & Reporting).
×
Subscribe to Incident
Subscribe to updates for
Portal Login Issues
via . You'll receive .