RAM Portal, RAM Live and RAM Assist are unavailable at this time due to an ongoing issue with the login flow

Incident Report for RAM Tracking

Resolved

Our Development team have rectified the issue and authenitcation into all our applications are now operational again.
Posted Jun 09, 2026 - 08:52 UTC

Investigating

We are currently investigating this issue with the highest priority
Posted Jun 09, 2026 - 07:34 UTC
This incident affected: RAM Assist (Assist Website), RAM Live (Live Website), and RAM Tracking (Tracking Website & Reporting, Tracking App).