Mobile network outage affecting devices reporting

Incident Report for RAM Tracking

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 22:09 UTC

Monitoring

We're starting to see processing improve and the backlog of messages come down. Devices that are able to connect will upload any stored data automatically.
Posted Dec 04, 2025 - 18:14 UTC

Identified

We are aware of an issue with one of our mobile networks that is impacting the ability of devices to connect to our servers. Data will be stored on the devices until they are able to come online
Posted Dec 04, 2025 - 13:53 UTC
This incident affected: RAM Tracking (Device Processing).