RAM Tracking website is unavailable, data processing not impacted

Incident Report for RAM Tracking

Resolved

This incident has been resolved.
Posted May 29, 2026 - 12:29 UTC

Update

We are continuing to investigate this issue.
Posted May 29, 2026 - 12:24 UTC

Update

Service is restored, monitoring performance
Posted May 29, 2026 - 12:01 UTC

Investigating

We are currently investigating this issue. Please use this site as an alternative https://portal.ramtracking.com/
Posted May 29, 2026 - 10:35 UTC
This incident affected: RAM Tracking (Tracking Website & Reporting).