RAM Tracking website is unavailable, data processing not impacted

Incident Report for RAM Tracking

Resolved

This incident has now been resolved. We apologies for any inconvenience caused.
Posted Jun 15, 2026 - 15:44 UTC

Investigating

We are currently investigating this issue.
Posted Jun 15, 2026 - 14:23 UTC
This incident affected: RAM Tracking (Tracking Website & Reporting).